Notifications
Clear all

Função Índice e Corresp para fazer a vez do Procv

3 Posts
3 Usuários
2 Likes
520 Visualizações
Leo43silva
(@leo43silva)
Posts: 27
Trusted Member
Topic starter
 

Bom dia a todos!

Estou tentando usar Índice e Corresp  para substituir a função Procv.

Mas não estou conseguindo fazer isso usando duas Planilhas.

Exemplo:

Planilha Resumo de Gastos:

Na coluna B17 "Açai" : trazer todos os gastos que foram feitos no mês de Julho que esta  na Planilha Despesas Mensais da G4 até G8.

Fórmula usada:=ÍNDICE(Despesas_Mensais!D4:D8;CORRESP(Resumo!A17;Despesas_Mensais!G4:G8;0))

Segue em anexo a planilha.

 
Postado : 19/07/2023 8:43 am
(@mago-da-planilha)
Posts: 4
Active Member
 

@leo43silva boa noite;

Acredito que a formula que você deseja é o SOMASES, para somar todos os valores (Gastos) no determinado intervalo que correspondam à palavra chave (Açai).

Como a sua planilha está formatada com tabelas, pode usar uma das seguintes formulas:

=SOMASES(Tabela14[Valor_Total];Tabela14[Descrição];[@Descrição])

ou

=SOMASES(Despesas_Mensais!G4:G8;Despesas_Mensais!D4:D8;Resumo!A17)

ou

=SOMASES(Despesas_Mensais!G4:G8;Despesas_Mensais!D4:D8;"Açai")

 
Postado : 25/07/2023 10:49 pm
Leo43silva reacted
(@luizhcosta)
Posts: 420
Honorable Member
 

Olá, reforçando o colega anterior, acho que sua fórmula deveria ser a SOMASE, mas se você tiver certeza do que quer;

=ÍNDICE(Tabela14[Valor_Total];CORRESP([@Descrição];Tabela14[Descrição];0))

 

Boa sorte

 
Postado : 28/07/2023 8:31 pm
Leo43silva reacted