Notifications
Clear all

Função SE + E  

  RSS

TIAGO987M
(@tiago987m)
New Member
Entrou: 9 anos atrás
Posts: 2
09/09/2020 10:30 am  

Planilha para controle de horas - controle de ponto.

Preciso de uma função que confirme alguns critérios e com base no resultado me retorne um valor.

 

Se o dia for igual a Domingo, portanto o valor da coluna deverá ser 07:20, mas para ser esse valor não pode ocorrer ainda os seguintes critérios;

Se total de faltas na Segunda, ou Terça,  Quarta, Quinta, Sexta, for maior ou igual a meio dia. Ai o Domingo ficará zerado.

 

Segue a Planilha em anexo!


ResponderCitar (Quote)
fabio.cmaa
(@fabio-cmaa)
Estimable Member
Entrou: 4 anos atrás
Posts: 169
09/09/2020 11:12 am  

 

 

coloca essa formula ai na O4,

 

=SE(SOMA(L4:L8)>=VALOR(TEXTO("04:18";"hh:mm"));"07:00";0)

 

Se foi isso que intendi, é isso! testa e me diz, caso não, ajustamos


ResponderCitar (Quote)
fabio.cmaa
(@fabio-cmaa)
Estimable Member
Entrou: 4 anos atrás
Posts: 169
09/09/2020 11:16 am  

@tiago987m

 

Dei uma melhorada >>>> =SE(D3="Dom";SE(SOMA(L4:L8)>=VALOR(TEXTO("04:18";"hh:mm"));"07:20";"00:00");"")


ResponderCitar (Quote)
TIAGO987M
(@tiago987m)
New Member
Entrou: 9 anos atrás
Posts: 2
10/09/2020 11:16 am  

@fabio-cmaa

Olá Fabio,

Consegui chegar ao resultado que eu queria. Primeiramente, tive que inverter os dois últimos argumentos na formula que você criou. Ficou assim;

=SE(D3="Dom";SE(SOMA(L4:L8)>=VALOR(TEXTO("04:18";"hh:mm"));"00:00";"07:20");"")

A fórmula funcionou, porem em partes. Não é a soma na semana que tem que ser >="04:18" para que se perca o direito ao DSR(07:20), mas sim se o total de um único dia exceder o valor "04:18", não importando em qual dos dias ou de quantas vezes venha a ocorrer no intervalo L4:L8.

Sendo assim, acrescentei a função OU e ficou da seguinte forma;

=SE(D3="Dom";SE(OU(L4>=VALOR(TEXTO("04:18";"hh:mm"));L5>=VALOR(TEXTO("04:18";"hh:mm"));L6>=VALOR(TEXTO("04:18";"hh:mm"));L7>=VALOR(TEXTO("04:18";"hh:mm"));L8>=VALOR(TEXTO("04:18";"hh:mm")));0;"07:20");"") 

Muito obrigado pela disposição e ajuda!


ResponderCitar (Quote)
fabio.cmaa
(@fabio-cmaa)
Estimable Member
Entrou: 4 anos atrás
Posts: 169
10/09/2020 1:46 pm  

@tiago987

 

Disponha meu amigo, eu vim ver que eu inverti, depois eu corrigi aquim, mas acreditava que você tambem iria perceber rsrsrs, por isso nem mandei corrigindo, que bom que solucionou seu problema..


ResponderCitar (Quote)
Compartilhar: