Notifications
Clear all

Saber a serie do aludo pela idade

7 Posts
4 Usuários
0 Reactions
1,001 Visualizações
(@silvagno)
Posts: 14
Eminent Member
Topic starter
 

Bom dia Pessoal,

Estou tentando tentando saber a serie do aluno de acordo com alguns critérios.

Ex: Se o aluno nasceu em 2019 e completa 4 anos até 31/03/2023 ele vai para o GRUPO 4, se ele completa 4 anos a partir de 01/04/2023 ele vai para o GRUPO 3.

Eu consegui fazer funcionar até um certo ponto, de pois a formula já não trazia o resultado correto.

Peço a ajuda de vocês. Obrigado

 

 
Postado : 04/06/2023 10:19 am
daphne
(@daphne)
Posts: 94
Estimable Member
 

@silvagno qual sua versão do excel?

 
Postado : 06/06/2023 2:44 am
(@silvagno)
Posts: 14
Eminent Member
Topic starter
 

@daphne Bom dia, Professional Plus 2016

 
Postado : 20/06/2023 11:24 am
Estevaoba
(@estevaoba)
Posts: 0
Eminent Member
 

Uso uma tabela (amarelo) e esta fórmula (laranja).

=ÍNDICE($F$2:$F$5;CORRESP(INT(FRAÇÃOANO(C2;$I$1));$G$2:$G$5;0))

O site está com erro que não permite o upload da planilha.

A tabela F2:G5 seria assim:

GRUPO 3 3
GRUPO 4 4
GRUPO 5 5
1º ANO 6

E usando a data em I1.

Good luck!

Este post foi modificado 1 ano atrás 4 vezes por Estevaoba
 
Postado : 20/06/2023 1:10 pm
(@silvagno)
Posts: 14
Eminent Member
Topic starter
 

@estevaoba Bom dia, fiz o teste e parece que esta faltando algo na formula, pois quando digito a data 01/04/2023 não altera o valor para GRUPO 3, assim como não esta pegando os que nasceram em 2018 e 2017.
Pode verificar por gentileza?

Desde já agradeço.

 
Postado : 17/07/2023 10:42 am
(@silvagno)
Posts: 14
Eminent Member
Topic starter
 

Alguém pode ajudar?

 
Postado : 23/08/2023 5:57 pm
(@osvaldomp)
Posts: 852
Prominent Member
 

Veja se atende. Cole uma cópia da fórmula abaixo em qualquer célula vazia e arraste para abaixo.

=PROCV(DATADIF(C2;H$1;"y")+1*(ANO(H$1)-ANO(C2)>DATADIF(C2;H$1;"y"))&"*";D$2:F$4;2+1*(ANO(H$1)-ANO(C2)>DATADIF(C2;H$1;"y"));0)

)

Osvaldo

 
Postado : 26/08/2023 3:09 pm